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Objective of Presentation

• Introduce SNAP
– A breakdown of the Model Editor Graphical User Inte rface 

(GUI)
– Discuss the various tools (Job Status, Configuratio n Tool)
– General discussion of functionality regarding MELCO R

• Demonstrate user input workflow
– MELGEN and MELCOR

» General “Packages” are maintained
» General User Guide information is accessible

• Demonstrate job submittal
• SNAP is a very feature rich suite

– Therefore we’ll focus on using it solely to create MELCOR 
input and perform calculations



• From a simple user’s understanding of 
information flow

Simplistic Idea on Information Flow for 
Job Submittal

Model Editor

Job Status Tool

Configuration Tool

Working Folder
Supporting Files

Executables
Calculation Server Initialization

Model Input



SNAP Model Editor

• Model Editor
– Unique plug-ins handle specific model details for a  given 

code (MELCOR, RELAP, etc.)
– Stores both MELGEN and/or MELCOR user input
– Can convert older MELGEN/MELCOR 1.86 input to 2.x
– Submits input processed by executables (i.e. job 

submittals)
– Can create an Animation Model for post processing o utput

• Model Editor Advanced
– User Defined Numerics
– Engineering Template
– Automated Validation Framework
– And more….



Model Editor Interface

Navigator

Property View

Views

Message Window



Navigator View

• Nodal based tree for each package
– Blue node can be clicked to expand the tree
– Select the MELCOR component to view its properties in 

the Property view (Components can be selected in ei ther 
the Navigator or the View port.)

– Packages with different names
» Model/Options == EXEC package
» Control Systems == CF/EDF/TF packages

– Internal Controls
» Cases – Where the MELCOR input is treated
» Job Streams – Identifies MELCOR input files and 

executables  using an information flow map
» Connections – list component dependencies
» Numerics – user defined substitutions to input
» Views – List of views available in the View port



Sub-Systems

• Sub-Systems allows user input to be grouped 
logically into system sets
– Components can be added to a sub-system from the 

currently available component
– Exporting a text files will maintain sub-systems in  

independent files (a typical practice for MELCOR fi le 
organization where components are stored in unique f iles)
» Example

• RHR components may include
– Pumps, reservoir water sources, heat exchangers, et c.
– Their associated flow paths, controls volumes, cont rolling logic 

are often kept primarily in one input file for book keeping 
purposes



Navigator View

• Multiple models can be open in one SNAP 
instance
– Harmonica Display

Navigator Collapsed Navigator Expanded



Properties and Message View

• Properties View
– Where all user input is accepted

» Both MELCOR and/or SNAP components
– Editable fields
– Drop down menu
– Editable window pop-ups
– Selectable elements
– Model notes 
– User guidance 

• Message 
– Where error messages associated with SNAP are place d.
– MELCOR error messages are still written to the MELC OR 

files
» Message file, diagnostic file, output file, etc.



View Port

• New Views are created in the Navigator tree
– Right click View, select new to create a new view 

component

• View components have several internal 
drawing methods for various components
– Components can be place in the view by right clicki ng on 

the component in the navigator tree and selecting ‘ add to 
view’

– Control Volumes utilize the CV_VAT information (Volu me 
and Altitude Table) when determining the depiction

– Flow paths utilize Connections (see Navigator tree) to 
determine which Control Volumes to connect.  Locati on of 
the connecting line is taken from the FL_FT record versus 
the CV_VAT input

– Core, Control Functions, Database Variables, etc.



Drawing in the View Port

• Drawing is very straight forward.  Experiment 
to learn
– Tools available

» Layers 
• Drawn components are assigned to a given layer
• Layers can be made visible or invisible making edit ing easier

» Docking
• View can be detached from the view port and moved a bout the 

desktop
– Right click the view in the Navigator>Undock View

» Standard copy/cut/past/zoom/pan controls
• CNT+C / CNT+X / CNT+P / CNT+MouseWheel / 

MouseWheel(Shift+MouseWheel)

» Grouping components, found in tool bar
» Lasso select (left click hold and drag)
(Continued)



Drawing in the View Port

– Tools available (continued)
» Connection Tool

• Components (Control Volumes, Flow Paths, and a few others can 
be initialized in the view port, likewise connectio ns can be created 
between such components with the connection tool)

» Drawing Tools
• Annotate

– Add text, lines, shapes, etc.
• MELCOR components

– Sprays, Control Volumes, Flow Paths, etc.
• Job Stream information flow maps

– Toolbar



View Port Toolbar

Lock View

Select Layer

Cut

Copy

Paste/Paste Special

Find

Group/Ungroup Selection

Select

Pan

Zoom Connect

Draw Tool



View Port Notes

• Interactive elements can only be selected 
from the View Port if the view is locked
– This is to prevent accidental interactions while ed iting the 

view components

• If the screen is locked you cannot edit any of 
the components

• Individual layers can be locked to prevent 
editing certain components

• Connections can only be made in the View 
Port for the following
– Flowpaths to Control Volumes, Sprays to Control 

Volumes, and Fan Coolers to Control Volumes



Example: Import MELGEN File

• Importing a pre-existing MELCOR model
– File > Import > MELGEN 2X

» Make sure the Code Version is correct
» Select the root file

• Note R*I*F or INCLUDE files are read with regard to  their hosting 
file not the main root file. (MELCOR performs these  functions with 
regard to the root file only.)

– Hosting file is the file with the R*I*F or INCLUDE file location
– Root file has the main MELGEN or MELCOR block

» Name options can be specified by the user
• Preserve existing component names as reasonable (16  character 

limit and repeated names will have an _# appended t o the end of 
the name)

• Generate with number
– With package prefix i.e. CV###
– Without prefix i.e. ##### 



Example: Import MELCOR File

• Within the Navigator Tree
– Add a Case if none exists (right click case select new)

» This will create a MELCOR Case
– Right Click the newly created MELCOR Case and selec t 

Import Case
– Navigate to file location

» If error Messages are overwhelming
• The “Code Version” didn’t match the file type

– 1.86 vs 2.x mismatch



Notes on Importing

• Review the Message View for import errors
– May require some corrections
– Once again if the error messages are overwhelming

» 1.86 vs 2.x mismatch likely occurred

• Import the MELCOR case BEFORE changing 
the “Code Flavor” i.e. from 1.86 to 2.x or 
reverse
– SNAP is anticipating like versions 



Converting the Models

• MELGEN Input
– Select Model/Options within the 

Navigator Tree
– Adjust Code Flavor within the 

Properties View to the desired 
input structure

• MELCOR Input
– Expand Cases in the Navigator 

Tree
– Right click the desired MELCOR 

input within the Navigator Tree 
– Select Edit Case



Converting the Models

• A new Navigator Tree for the MELCOR input 
will be generated

• The functionality is very similar to the 
MELGEN input Navigator Tree
– Select Model/Options within the Navigator Tree
– Adjust Code Flavor within the Properties View to th e 

desired input structure
– Click the Save Icon near the top of the Navigator T ree 

(which will close the MELCOR Navigator Tree)



Configuration Tool

• General Use
– Lets SNAP know where the 

executables are located
» MELGEN/MELCOR
» APT Plot (Not necessary but 

useful for Post Processing)
– Initiates the Calculation Server 

» Calculation Server is where the 
calculations are performed

» By default your current 
machine is assumed to be the 
calculation server

• Therefore if your machine is the one 
to perform the calculations you will 
not need to adjust this setting



Configuration Tool Setup

• Personal Setting
– APT Plot location can be specified

» As well as other tools if so desired
– Server Status 

» Click the play button, there are several other user  
actions that can start the Server.

• Applications
– Right click Applications > New > MELGEN > location of 

MELGEN
– MELCOR (same as MELGEN)
– Specify the Server

» If your machine will perform the calculations no fu rther 
work is necessary



Job Status Tool

• Job Status Tool
– Keeps track of prior performed jobs
– Only displays the folder list and jobs when the Cal culation 

Server has been started 



Job Status Tool Setup

• User will need to create a working folder
– Right click Local > Mount Root Folder
– Specify the working folder

• Job Streams can be submitted to any 
mounted root folder
– The files submitted and produced by MELGEN and 

MELCOR will be located in \Root Folder\Job Stream N ame

• From an existing Job
– Files associated with the run can be viewed with th e Job 

Status Tool
– Data can be plotted with APT Plot from the Job Stat us Tool 
– Jobs viewable from the Job Status Tool will be avai lable 

for post processing with an Animation Model from th e 
Model Editor



Importing a Standalone Job with the Job 
Status Tool

» The Job must reside in a folder within the working 
directory of a mounted Root Folder

» Navigate down to the folder where the Job files res ide
» Right click the folder>Import Completed Job
» Select the applicable application
» Click Next then input a Job Name if desired 
» Click Next then select the location of all desired files



Creating a Job Stream

• Job Stream
– Created within the Model Editor
– Performs MELGEN and/or MELCOR runs

» Can be either or both
– Submits the input files to the MELGEN/MELCOR 

executables and specifies the folder where the resu lts will 
be placed

– Produces a new Job within the Job Status Tool
– Can specify the post processing tool to generate a set of 

plots
– Has several default Job Streams which can be select ed to 

simplify the setup process



Setting Up a Job Stream

• Checklist before setting up a Job Stream
– MELGEN/MELCOR executables setup in the Configuratio n 

Tool
– Calculation Server started
– Root Folder present in the Job Status Tool where th e 

resulting files will be located

• Set-up
– In the Navigator right click Job Streams>New
– Select Basic Stream
– Select calculation type (Two-Step)
– A new View will be created containing an informatio n flow 

diagram
» The MELGEN input and MELCOR input will be present
» A MELGEN and MELCOR executable will be selected 

from the Configuration Tool automatically



Job Stream

• Independent files can be specified in the Job 
Stream
– Restart Files, ASCII Input Files, etc.

• Sensitivity cases can be performed
– If a Numeric has been included in the model it can be used 

to perform various like calculation where the Numer ic 
value is varied
» Create a new numeric by expanding Numeric tree and 

right clicking desired Numeric type 
» Create a Numeric Job Stream and edit the Parametric  

Properties
» Edit the Parametric Tasks



Example: Continuation of Import 
Example with Job Stream Creation

• Performed during the workshop



Post Processing with SNAP

• Animation Model is a separate model from the 
MELCOR model
– File>New select Animation model



Creating a Basic Animation Model

• Attaching a plotfile
– Two Steps

» Click on Master in the Data Source Tree in the 
Navigator and set the Source Run URL in the 
Properties to a completed Job

» Click the Data Connector Icon

• Create a Color Map
– Three steps

» Right Click Color Maps in the Navigator>New
» Right Click the new Generic Color Map>Add To View
» Adjust some Properties

• Set Color Map Type to Generic
• Specify Dynamic as True
• Set Channel Name Pattern to MELCOR “CVH-P_%V”

– Review the MELCOR User’s Guide to see all the avail able plot 
channels 

– %V is a place holder for the components Control Vol ume 
number (see notes for a detailed description on its  use)



Creating a Basic Animation Element

• Creating a Polygon
– Select Polygon from the 

Annotation section of the 
View Port Toolbar (review 
earlier slides if you can’t 
remember what the 
Toolbar looks like)

– Start clicking in the View 
port and the drawing logic 
will become clear (left click 
to set a point, right click to 
remove the last point)

– If you click on top of an old 
point it will close the 
polygon and the instance 
will be complete.



CVH-FL Example Problem: Drawing the 
Wetwell

• Set the following
– Color Maps
– Enable Use Level Data / set the Liquid Level Data C hannel
– Specify Volume IDs
– Max and Min Levels
– Adjust the Upper Phase Mode to One Phase


